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1. Introduction

e Itis an implementation of optical flow algorithm with OpenCV and
Visual Studio 2017 (any Visual Studio version can be used, but better
to get VS2017) using VC++.

e This guide shows steps for VS2017 with OpenCV 2.4.9 on Windows
10. (We recommend you to do this assignment with the same
versions to avoid any unexpected errors/issues)

* Implementation can run either real time to track moving objects
(using webcam) or between two frames.



Visual Studio 2017 - Installation

Download the Visual Studio 2017 (Community version) from the following link: https://visualstudio.microsoft.com/downloads/

(For Mac OS, select MacOS from the top right of this webpage (see purple arrow))

h

Downloads

Visual Studio 2017 Visual Studio Code

Full-featurad integrated development environment (IDE) for Android, The fast, free and open-source code
105, Windows, web, and cloud editor that adapts to your needs
Community Professional Enterprise
Powerful IDE, free for Professional IDE best Scalable, end-to-end

Version: 15.8 students, open-source suited to small teams solution for teams of any Release notes

Release notes contributors, and size Free download &
individuals

By downloading and using Visual Studio

i i Code, you agree to the license terms and
Free download & I Free trial J& Free trial & privacy statement,

Download Preview Download Preview Download Preview

Compare editions

How to install offline



https://visualstudio.microsoft.com/downloads/

Visual Studio 2017 - Installation

Open the installer once it has been downloaded.
Follow through the instructions till you reach to this window:

Medifying — Visual Studio Community 2017 Preview — 15.9.0 Preview 4.0 X
Workloads Individual compenents Language packs Installation locations

Windows (3) Installation details

v Visual Studio core editor
The Visual Studio core shell experience, including syntax-
aware code editing, source code control and work item
management.

NET desktop development 'L_,_:I Desktop development with C++
Build WPF, Windows Forms, and console applications Build Windows desktop applications using the Microsoft

| Basic, and F#. C++ toolset, ATL, or MFC.

mMl Universal Windows Platform development
ndows Platform

Create applications for the Universa
with C#, VB, JavaSeript, or optionally C++

Web & Cloud (7)

@ ASP.NET and web development IA Azure development

Build web applications using ASP.NET, ASP.NET Core, Azure SDKs, tools, and proje

 developing cloud apps,

HTML/JavaScript, and Containers including Docker suppo sating <es, and building Containers indluding...
ﬁ Python development =) Nedejs development
Editing, debugging, interactive development and source Build scalable network applications using Node js, an

control for Python. asynchronous event-driven JavaScript runtime.

Location
C:\Program Files (x86]\Microsoft Visual Studio\Preview\Community Change...
Total space required -13.72 GB

By continuing, you agree to the license for the Visual Studio edition you selected. We also offer the ability to download other software with Visual Studiio. This software
is licensed separately, as set out in the 3rd Party Notices o in its accompanying license. By continuing, you also agree to those licenses.

Install while downloading ~




Visual Studio 2017 - Installation

Select the following Workloads:
— .NET desktop development
— Desktop development with C++
— Universal Windows Platform development
— Visual Studio Extension development

Then select “Install while downloading” option from dropdown button at the
bottom right of the opened window.

Click the install button.

It might take longer depending on the computer (for a 64-bit CORE i3 machine
with 4GB RAM, it took couple of hours at least).
You will need to reboot your machine once everything is installed.



0 2. OpenCV

O

OpenCV

e OpenCV (Open Source Computer Vision Library) is an open source
computer vision and machine learning software library.

e OpenCV was built to provide a common infrastructure for computer
vision applications and to accelerate the use of machine perception
in the commercial products.



 The library has more than 2500 optimized
algorithms, which includes a comprehensive set of

both classic and state-of-the-art computer vision
and machine learning algorithms.

Pattern
Signal Recognition
Processing

Image
Computer Processing
hgsics Vision

Artificial
N eiratic: Intelligence



® These algorithms can be used to:
o detect and recognize faces,
identify objects,
classify human actions in videos,
track camera movements,
track moving objects,
extract 3D models of objects,
produce 3D point clouds from stereo cameras,
etc.

O O O O O O O
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e |t has C++, C, Python, Java and MATLAB interfaces
and supports Windows, Linux, Android and Mac OS.

C/C++

$ Java
@ python’

1 b U5



3. Downloading the Required Software

* Download from (opencv.org) or any other website
that offers the download. You can download from
the given link below:

http://sourceforge.net/projects/opencvlibrary/files/
opencv-win/2.4.9

e For this tutorial, version 2.4.9 will be used.


http://sourceforge.net/projects/opencvlibrary/files/opencv-win/2.4.9

4. Installing OpenCV

e Installation requires about 4GB of free disk space.

 Run the downloaded executable file (Note that the OpenCV installer
simply creates a folder named “opencv” in the chosen “Extract

to:"directory).

Extract Cancel




* You should choose an extraction directory that is safe, accessible,
and unlikely to change. This guide uses an “Extract to:” directory of

{lc:\” .

¥
L

Hap=sed time:
Remaining time:
Files:

Compression ratio:

Baclcground

1% Extracting

o0 -Oed- 1 0D Total size:
000344 Speed:
0 Processed:

Compressed size:

Fause

— O

38310 MB
F304 KBss
72 MB

Cancel




 When it closes, confirm that the opencv directory
was created in your Extract to: directory of choice:

Home Share View
(€) () ~ 1T @& » ThisPC » Local Disk (C:) v ¢ | Search Local Disk (C:) P

'ﬂ‘ Home Mame Date modified Type

_ . opencv 4/15/2014 533 AM File folder
Favorites : - :
. Program Files 11/9/2014 3:44 PM File folder
S Onelrive . Program Files (x86) 111672004 %44 AR File folder
_ _ . Users 11/9/2014 3:44 PM File folder
[z This PC | Windows 11/17/2014 10:28 ... File folder
IFE' Metwork ; Windows.old 11/9/2014 6:36 PM File folder
<

& items 1 itemn selected ==
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< Dropbox

* Then, go to https://www.dropbox.com/login and then sign in using
the following information:

Email: robot.vision.files@gmail.com,

and Password: robotvision

e Download the OpticalFlow_vs.zip file on your computer.

Note: This folder contains the implementation for Optical Flow
assignment.


https://www.dropbox.com/login
mailto:robot.vision.files@gmail.com

5. Start a new Visual C++ Project for
Optical Flow

File -> New -> Project

’Sj Start Page - Microsoft Visual Studio Preview
File | Edit View Project Debug Team Tools Test Analyze Window  Help

New Y i3 Project... Crl+Shift=N -
Open Y File. Ctrl+N

@& Start Page Project From Existing Code...
Close [ —

Close Solution

Save Selected ltems Ctrl+5 G et Sta rte d O pen

Get code from a rer

Save Selected ltemns As... -
open something or

i save sl Ctrl+Shift+5 Build your first app in 5 minutes!

Checkout from:
Source Control & Maximize your productivity with these tips and tricks for Visual Studio

< Azure DevOps
Page Setup... Take advantage of the newest technologies to deploy beautiful, low-cost and
Print... Ctrl+P reliable websites

R Open Project /
Account Settings... Develop medem, fully-native, Android and i0S apps

= Open Folder
Recent Files 3
Recent Projects and Solutions [ % Open Website

Exit Alt+F4 R eC e n t




e Visual C++ -> Windows Console Application
e Write the name you choose for the project. For example, Optical_Flow

* Then, Press OK.

Numbers with

arrows in the figure

shows steps.

Mew Project

I Recent

1
4 Installed /

4 Visual C++
Windows Desktop
Windows Universal

b Cross Platform

MFC/ATL
Test
Other
Extensibility

p Other Languages

b Other Project Types

I Online

Not finding what you are looking for
Open Visual Studie Installer

Mame: Optical_Flow

Sort by: | Default -]

Z

E
+

Windows Consecle Application

Empty Project

Windows Desktop Application

[ 3 - Rename the project

\Lz

Visual C++

Visual C++

Visual C++

Location:

|c\usershwision\sourcelrepast

Solution name:

Optical_Flow

Search (Ctrl+E)

Type: Visual C++

A project for a command-line .exe

application that runs on Windows.

Browse...

Create directory for solution

D Add to Source Control

Cancel

= e

Z T T =

=TT

= o




You will see the following window, when the project has been successfully created.

A Optical_Flow - Microsoft Visual Studio Preview X & QuickLaunch (Ctrl+Q) Pla B X
File Edit View Project Build Debug Team Tools Test Analyze Window Help Aisha Urooj = [
= e T - - | Debug - |x86 - P Local Windows Debugger = Auto SlALEEGE A e A =
z o
Solution Explorer L Bl Optical Flow.cpp + X - &
G- mrs @@ o ;E %] Optical_Flow ~|  (Global Scope) -| N
- 1 / Optical Flow.cpp : This file contains the 'main’ function. Program executicn begins and ends there. ==
Search Solution Explorer +:} P~ ; = ]
2 -
1 Solution "Optical_Flow' (1 project) r
4 %] Optical Flow 4 Elinclude “pch.h g
b il Refsrdhcis include <iostream: g
b iE Ext I D d 2 .
5 External Dependencies = Sint main() o
b 5 HeaderFiles 3 { 3
7 Resource Files std::cout << "Hello World!\n"; 5
b 35 Source Files } a
=// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
13 // Debug program: F5 or Debug > Start Debugging menu
15 =// Tips for Getting Started:
/ 1. Use the Solution Explorer window to add/manage files
7 // 2. Use the Team Explorer window to connect to source control
8 I 3. Use window to see build output and other messages
/4. Use or List window to view errors
// 5. Go te Project » Add New Item to create new code files, or Project > Add Existing Item to add existing code files to the project
Y 6. In the future, to open this project agein, go to File > Open > Project and select the .sln file
-
100% =~ 4 ¢
Output
Show output from: | Debug
ELIN LD RSt IR Class View  Property Man.. Team Explorer

] Ready 4 Add to Source Control =

O Type here to search 0




 Then, close the project.

* File -> Close Solution
ﬂE Optical_Flow - Microsoft Visual Studio Preview _ ' & | Quick Launch (Ctrl+Q)

File | Edit View Project Build Debug Team Tools Test Analyze Window  Help
New Pl - xB6 = P Local Windows Debugger = Auto | '

i
I
) |
1

Open 3
Start Page

Optical_Flow.cpp # X

[ Optical_Flow - (Global Scope) -
HEElim S i o 1 -1// Optical Flow.cpp : This file contains the 'main’ function. Program execution begins and ends there.
Add s 2 1/
3
Close 4 Sl#include "pch.h"
B]  Close Solution 5 #include <iostream:
5
I Save Optical_Flow.cpp Ctrl+5S 7 Siint main()
Save Optical_Flow.cpp As... 8 {
: g . " I ™
W Save Al Ctrl+ ShifteS ; std::cout << "Hello World!'n";
Source Control r
12 =// Run program: Ctrl + F5 or Debug » Start Without Debugging menu
[  Page Setup... 5 .
13 // Debug program: F5 or Debug > Start Debugging menu
= Print... Ctrl+P 14
. 15 -// Tips for Getting Started:
A t Settings... . . .
ceoun 1ngs 16 // 1. Use the Solution Explorer window to add/manage files
Recent Files 3 17 /f 2. Use the Team Explorer window to connect to source control
Recent Projects and Solutions o '78 /f 3. Use the Output \:.llndo\:.' to see bL:llld output and other messages
19 // 4. Use the Error List window to view errors
Exit Alt+F4 28 // 5. Go to Project > Add New Item to create new code files, or Project > Add Existing Item to add existing code files to the project
21 // 6. In the future, to open this project again, go to File > Open > Project and select the .sln file

00 %6 -~ d



* Copy the following files (listed on next slide)

From: OpticalFlow_vs directory (the extracted zip file you have already downloaded from the
Dropbox).

<the directory that contains the extracted zip file>\
OpticalFlow_vs\OpticalFlow_vs\OpticalFlow_vs\OptiFlow

For example, C:\OpticalFlow vs\OpticalFlow_vs\OpticalFlow vs\OptiFlow

To: the project folder
<the new project directory>\Optical_Flow\Optical Flow
For example, C:\Users\Vision\source\repos\Optical Flow\Optical Flow



between.h between.cpp image0.jpg
common.h cv_pyrlk.cpp imagel.jpg
resource.h main.cpp stdafx.h
Tracker.h Tracker.cpp stdafx.cpp

targetver.h




* In the new project directory, perform the following steps:

1. Delete the cpp file that contains the main function (its name is the
same as the project name).

For example, delete
C:\Users\Vision\source\repos\Optical Flow\Optical Flow\Optical Flow

CPp

2. Rename main.cpp to be the same name as the deleted file.



e Copy all dll files

From the following directory:
<OpenCV install directory>\build\\x86\vc11\bin
For example, C:\opencv\build\x86\vc11\bin

To
<the new project directory>\Optical _Flow\Optical Flow
For example, C:\Users\Vision\source\repos\Optical Flow\Optical Flow



e Then, open the project again.
* File -> Open -> Project/Solution

ﬂ Start Page - Microsoft Visual Studio Preview

File

Edit View Project Debug
Mew
Open
Start Page
Close

Close Solution

Save Selected ltems
Save Selected ltemns As...
Save All

Source Contral

Page Setup...

Print...
Account Settings...

Recent Files

Recent Projects and Sclutions

Exit

Team  Tools

> |
[

Ctrl+5
Ctrl+5hift+5

3
Ctrl+P

»

3
Alt+F4

i}

2

-

[u]

Test  Analyze  Window  Help

p Attach.. - | - .
Project/Solution... Ctrl+ Shift+0 _
Folder... Ctrl+Shift+ Alt+ O
Web Site... Shift+Alt+0
CMake...

Open from Source Control

File... Ctrl+O

Convert..,

Maxirmize your productivity with these tips and tricks for Visual Studio

Take advantage of the newest technelogies to deploy beautiful, low-cost and
reliable websites

Develop modern, fully-native, Android and 105 apps

Recent

Today



Select the Optical_Flow.sln file from the newly created Optical _Flow
project directory. Click Open.

> Open Project x
« v 4 » Vision * source * repos » Optical_Flow » v ) Search Optical_Flow 2
Organize MNew folder =~ ™ @
- Mame Date medified Type Size
7 Quick access
NE 10/31/2018 215 PM  File folder
I Desktop _ _
Optical_Flow 10/31/2018 42 PM File folder
‘_’DDW”'““ [42 Optical_Flow 10/31/20189:15PM  Microsoft Visual S... 2 KB
g || Documents
| Pictures
Optical_Flow
Optical_Flow_fir
OpticalFlow_vs
OptiFlow
[ Dld Microsoft Visual 5
repos
W
File name: | Optical_Flow v| All Project Files (*.sln;™.dsw*wve




e Now, we need to add the source files (copied from Dropbox project
to our project directory in previous step) to our solution.
e Right click on “Source Files” -> Add -> Existing Item

ﬂj Optical_Flow - Microsoft Visual Studio Preview PREVIEW
File  Edit VWiew Project Build Debug Team  Tools Test Analyze Window  Help
< | FE Rl - | H"| - -| Debug - x86 = P Local Windows Debugger ~ Auto =
Solution Explorer AR W Cptical Flow.cpp ® X
@ e _| B-5 a @ | o ﬁIEI %] Optical_Flow +|  (Global Scope) =
1 /i main.c
Search Selution Explorer (Ctrl+;) P~ 2 PP
&1 Selution 'Optical_Flow' (1 project) 3 = "stdafx.h”
4 [%] Optical_Flow f ::corrrmn.h""
b =B References ; "betw:en.:"
b g External Dependencies ; Tracker.
bos HEEdErF”E.S 3 =lint main{int argc, char* argv[])
4 Resource Files g {
IW_I i e amElR] — LA Le
Add * 3 Mew ltem... Ctrl+Shift+A rgv[1] : “"camera");
g*  Class Wizard... Ctrl+Shift+X *a  Existing ltem... Shift+Alt+ A 5;)2{ . .
F— o — etween frames
pe to This ew Filter , NULL);
Mew Solution Explorer View H Class.. “camera")) {
o eo in real time
b Cut Bt % Resource.. new Tracker(20 /*n corners®/, 4 /*win size®/);
[l Copy Ctrl+C 18 tracker->start();
g FaIRT, 19 delete tracker;
Paste Sl 28 } return (B);
X Delete Del 51 }
Rename 22
23
& Properties Alt+Enter
100% -~




 Then, choose all h (header) and cpp files.
e Numbers with arrows shows steps.

“_gj Optical_Flow - Microsoft Visual Studio Preview
File Edit View Project Build Debug Team  Tools
G- | [ o | - - | Debug ~ x86

Solution Explorer * 0 X
@& o-c a@| L=
Search Selution Explorer (Ctrl+;) P~

fa] Solution 'Optical_Flow' (1 project)
4 [%] Optical_Flow
b =B References
= External Dependencies
5 Header Files
+ Resource Files

Ell Source Files

4

PREVIEW X &  Quick Launch (Ctrl+Q)

Test  Analyze Window  Help

P Local Windows Debugger ~ Auto - | AN _

¢ Add Existing Item - Optical_Flow
4N » Vision » source » repos » Optical_Flow » Optical_Flow v Search Optical_Flow

Organize MNew folder 2

~ MName Date modified Type

7 Quick access
[ Desktop
‘ Downloads

|k between 10/30/2018 11:54 C++ Source File
| between 10/30/2018 11:54 C Header File 1KB
|l commen 10/30/2018 11:54 C Header File 1KB
= Documents & cv_pyrlk 10/30/2018 11:54 C++ Source File 4KB
=| Pictures | Optical_Flow 10/30/2018 11:54 C++ Source File 1KB
Optical_Flow H pch 10/31/2018 %:15PM  C++ Source File 1KB
Optical_Flow i peh 10/31/20189:15PM € Header File 1 KB
Optical_Flow.fir: H stdafx 10/30/2018 11:54 C++ Source File 1KB
| stelafx 10/30/2018 11:54 C Header File 1KB
sk targetver 10/30/2018 11:54 C Header File 1KB
Dld Microsoft Visual § H Tracker 10/30/2018 11254 C++ Source File 5KB

repos [k Tracker 10/30/2018 11:54 C Header File 1KB
v

OptiFlow

File name: |"between" "between" "common” "ov_pyrlk" "Optical_Flow" "pch" " V| Visual C++ Files (".c; ".cpp; "ot ~

Add |+ Cancel



e VS2017 creates pch.h and pch.cpp files for precompiled headers. Since we copied
stdafx.h and stdafx.cpp, we need to remove pch.* files to avoid errors for the

sake of this project.
e NOTE: Read more about when they are useful in this link

If you are interested.
Do the following:

e Remove pch.h and pch.cpp from the “Source Files” i.e.
e Right click on “pch.cpp” -> Remove -> Delete -> Ok
e Repeat for “pch.h”

Note: You may not see the pch.h file under the
“Source Files”. In that case, just delete pch.cpp

Solution Explorer * @ X
@ o-5 B f-
Search Solution Explorer (Ctrl+;) P~

fa] Solution 'Optical_Flow' (1 project)
4 [%] Optical_Flow
=B References
P I'g External Dependencies
P 5 Header Files
4| Resource Files
P *+ between.cpp
B [A between.h
B common.h
B+ ov_pyrlkcpp
P *+ Optical_Flow.cpp
++ stdafx.cpp
[ stdafeh
targetver.h
P *+ Tracker.cpp
B [8 Tracker.h



https://hownot2code.com/2016/08/16/stdafx-h/

6. Editing the Project Properties

e Open the Project
Properties window via
the Solution Explorer
view.

e Right click
Project>Properties

Solution Explorer

Y B -

Search Solution Explorer (Ctrl+;

©-5 8w s

] Solution 'Optical_Flow' (1 project)
Opt

4
P

LT

> 0 X

&

wn | B

T

T

v T W v Vg

=k

K
i

q

s

[T S S Y

=

+

=

X

Build

Rebuild

Clean

View

Analyze

Project Only

Retarget Projects

Scope to This

New Solution Explorer View
Build Dependencies

Add

Class Wizard...

Manage NuGet Packages...
Set as StartUp Project
Debug

Source Control

Remove

Rename

Unload Project

Rescan Solution

Display Browsing Database Errors
Clear Browsing Database Errors
Open Folder in File Explorer

Properties

Ctrl+Shift+X

Alt+Enter

T



Optical_Flow Property Pages

? X

Configuration: | Active(Debug) ~ | Platform: |Active(Win32) w Configuration Manager...
4 Configuration Properties v General
Genera B o 1
Debugging Windows SDK Version 10.0.17134.0
VC++ Directories Output Directory S(SolutionDin) S{Configuration)’,
boC/C++ Intermediate Directory §(Configuration]’,
b Linker Target Mame S(ProjectMarme)
b= e Target Extension JEXE
e Generatur Extensions to Delete on Clean *.cdfi*.cache™ obj*.cbj.enc®ilk;*.ipdb;*.iobj* resources; ™ tlb; i
E EL?;‘:‘;'::;”’”“'”” Build Log File $(IntDir) S(MSBuildProjectName).log
) Platform Toolset Visual Studio 2017 (v141)
[ Custom Build Step -
b oTrimie e Enable Managed Incremental Build Mo
+  Project Defaults
Configuration Type Application (.exe)
Use of MFC Use Standard Windows Libraries
Character Set Use Unicode Character Set

Commen Language Runtime Support
MET Target Framework Version
Whole Program Optimization
Windows Store App Support

Mo Common Language Runtime Support

Mo Whele Program Optimization
Mo

Target Platform

The current target platform of the project.

Cancel

Apply




Select VC++ Directories on the left pane of the
Project Properties window.

Optical_Flow Property Pages ? X
Configuration: | Active(Debug) ~ | Platform: |Active(Win32) ~ Configuration Manager...
4 Configuration Properties v General
General Executable Directories S{(WC_ExecutablePath_x86); S(WindowsSDK_ExecutablePath);S(V5_E
Debugging Include Directories $(VC_IncludePath):S(WindowsSDK_IncludePath);
Reference Directories S(WC_ReferencesPath_x86);
bC/C++ Library Directories S(VC_LibraryPath_x26); S (WindowsSDK_LibraryPath_x26); S(METFXK
b Linker Library WinRT Directories §(WindowsSDK_MetadataPath);
b Manifest Tool Source Directories S(WC_SourcePath);
ol L LE ST SR Exclude Directories $(VC_IncludePath);S(WindowsSDK_IncludePath):$(VC_ExecutableF
> Browse Information
[ Build Events
I Customn Build Step
I: Code Analysis
g
Executable Directories
Path to use when searching for executable files while building a VC++ project. Corresponds to environment
< > wvariable PATH.
Cancel Apply




6.1 Adding the OpenCV Include Directories

e Edit the Include Directories to point to include the
three following directories:

<OpenCV install directory>\build\include
<OpenCV install directory>\build\include\opencv
<OpenCV install directory>\build\include\opencv2



Optical_Flow Property Pages ? oy
Configuration: | Active(Debug) ~ | Platform: |Active(Win32) ~ Configuration Manager...
4 Configuration Properties v General
General Executable Directories S(VC_ExecutablePath_x88):5(Windows5DK_ExecutablePath):5(V5_E
Debugging $(VC_IncludePath);S(WindowsSDK_IncludePath); ~
VC++ Directories Reference Directories <Edit..>
b C/C++ Library Directories IV _CIOTaTy P a T _Ro0]; STV IO WSSO T _CTOTa Ty a N _Re0]; STTVE TTAR
b Linker Library WinRT Directories $(WindowsSDK_MetadataPath):
b Manifest Tool Source Directories S(VC_SourcePath):
b G e B Exclude Directories $(VC_IncludePath);$(WindowsSDK_IncludePath):S(VC_ExecutableF
[ Browse Information
[ Build Events
[ Custom Build Step
I Code Analysis
Include Directories
Path to use when searching for include files while building a VC++ project. Corresponds to environment
< 3 variable INCLUDE.
Ok Cancel Apply




* For example, if your install directory was C:\opencyv, include the three following directories:
C:\opencv\build\include

Numbers in the left figure shows the

C:\opencv\build\include\opencv Steps. |
:\0p P 1. Adds new line
. . 2. Browseto the directories you
C:\opencv\build\include\opencv2 wish to add.
Include Directories 4 X Include Directories ? X
[ | ] ~ Chopencvibuild\include\opencv
4 I | Chopencvibuildiincludeopency E
| | Chopencvibuildyinclude 1
v
| L4 > F
1 L
Evaluated value: Evaluated value: c
C:\Program Files (x86)\Microsoft Visual Studic\Preview\Communityh A | Chopencvibuildiincludehopencv? ~| B
CA\Program Files (x86)\Microsoft Visual Studioh\Preview\ Community® Chopencvibuildiincludelopency |
v g v
I L 4 > j| € >
Inherited values: ) Inherited values:
S(VC_IncludePath) S(VC_IncludePath)
S(WindowsSDE_IncludePath) SWindowsS5DK_IncludePath)
Inherit frem parent or project defaults Macros> > Inherit from parent or project defaults Macros> >
oK Cancel QK Cancel

NOTE: You can either copy these three lines directly or browse to them to select the directories.



6.2 Adding the OpenCV Library Directories

e Edit the Library Directories to include the following
directory:

<OpenCV install directory>\build\x86\vc11\lib



Optical_Flow Property Pages

Configuration: | Active(Debug)

| Platform: | Active(Win32)

7 X

w Configuration Manager...

4 Configuration Properties
General

Debugging

YC++ Directories
C/C++

Linker

Manifest Tool

XML Document Generator
Browse Information
Build Events

Custom Build Step
Code Analysis

A A A A

~ General
Executable Directories
Include Directories

Reference Directories

Library Directories

S(VC_ExecutablePath_x86): 5(Windows5DE_ExecutablePath):5(V5_E
Chopenoibuild\includeh\opencv2;Chopenavibuild\include\ope
S(VC_ReferencesPath_x26);

3):5(Windows5DE_LibraryPath_xB6); S{METFXKitsDir)Lib\um'\x86

Library WinRT Directories

<Edit...>

Source Directories
Exclude Directories

IV _SUUTCEFILT];

SV _IncludePath): S (WindowsSDE_IncludePath): 50V C_ExecutableF

Library Directories

Path to use when searching for library files while building a VC++ project. Corresponds to environment variable

LIB.

OK Cancel Apply




* For example, if your install directory was C:\opencv, add the following library directory:
C:\opencv\build\x86\vc11\lib

| Library Directories ? >

Chopenod build\x88ywc 1 T\ lib

| Evaluated value:

ChopencdbuildyxB8vwc1Thlib e
4| C\Program Files (xB8)\Microsoft Visual Studio'Preview\Community

W
< >

7 Inherited values:

S(VC_LibraryPath_x26)
S(Windows5DK_LibraryPath_x26)
S(METFXEtsDhr)Lib um'x86

o

Inherit from parent or project defaults Macross >

QK Cancel




6.3 Referencing Required OpenCV Libraries

* To add OpenCV libraries, you must add the .lib files to
Linker>Input>AdditionalDependencies.

Configuration: | Active(Debug) ~ | Platform: | Active(Win32) ~ Configuration Manager...
4 Configuration Properties b;uuid.lib;odbe32.lib;odbecp3a.lib; %alAdditionalDependencies) «
General Ignore All Default Libraries |<Edit...>
Debugging Ignore Specific Default Libraries
VC++ Directories Module Definition File
b C/C++ Add Module to Assembly
4 Linker Embed Managed Resource File
General Force Symbol References
nput Delay Loaded Dlls
ManlfesF Lk Assembly Link Resource
Debugging
System
Optimization

Embedded IDL
Windows Metadata
Advanced
All Options
Command Line
Manifest Tool
XML Document Generator

Browse Information
Build Events
Custom Build Step Additional Dependencies

Code Analysis Specifies additional items to add to the link command line. [i.e. kernel32.lib]

Aol -

QK Cancel Apply



opencv_calib3d249.lib
opencv_calib3d249d.lib
opencv_contrib249.lib
opencv_contrib249d.lib
opencv_core249.lib
opencv_core249d.lib
opencv_features2d249.lib
opencv_features2d249d.lib
opencv_flann249.lib
opencv_flann249d.lib
opencv_gpu249.lib
opencv_gpu249d.lib
opencv_highgui249.lib
opencv_highgui249d.lib
opencv_imgproc249.lib
opencv_imgproc249d.lib
opencv_legacy249.lib
opencv_legacy249d.lib
opencv_ml249.lib
opencv_ml249d.lib
opencv_nonfree249.lib
opencv_nonfree249d.lib
opencv_objdetect249.lib
opencv_objdetect249d.lib
opencv_ocl249.lib
opencv_ocl249d.lib
opencv_photo249.lib
opencv_photo249d.lib
opencv_stitching249.lib
opencv_stitching249d.lib
opencv_superres249.lib
opencv_superres249d.lib
opencv_ts249.lib
opencv_ts249d.lib
opencv_video249.lib
opencv_video249d.lib
opencv_videostab249.lib
opencv_videostab249d.lib

Copy and paste the .lib files listed here into Additional
Dependencies (left figure).

| Additional Dependencies

| Additional Dependencies

opencv_videostab249.lib
opency_videostab249d.lib

Evaluated value:

Evaluated value:

%(AdditionalDependencies)

ocpencv_calib3d249.lib
opency_calib3d249d.lib
opency_contrib249.lib

Inherited values:

Inherited values:

kernel32.lib
user3.lib
gdi32.lib
winspoel.lib

kernel32.lib
user3llib
gdi32.lib
winspool.lib

Inherit from parent or project defaults

Inherit from parent or project defaults

: Copying them from the slide may introduce some extra spaces at the end of each line which may result in errors. Instead,

copy them from the following text file:
(https://docs.google.com/document/d/13a5ehxuOc3DNDamqgYrc7RnCpNjDUwqOI4Vn9J9i3apo/edit).




6.4 The Preprocessor Definitions

e C/C++-> Preprocessor ->Preprocessor Definitions

Configuration: | Active(Debug) ~ | Platform: | Active(Win32) ~ Configuration Manager...
4 Configuraticn Properties T T S WiN32; DEBUG; CONSOLE%(PreprocessorDefinitions) |~
General Undefine Preprocessor Definitions <Edit..>
Debugging Undefine All Preprocessor Definitions <inherit from parent or project defaults>
VC++ Directories Ignore Standard Include Paths T
4 C/Ces Preprocess to a File Mo
Gen_era.l ] Preprocess Suppress Line Numbers No
Optimization Keep Comments Mo
Preprocessor
Code Generation
Language
Precompiled Headers
Output Files
Browse Information
Advanced
All Options
Command Line
I Linker
I Manifest Tool
I XML Document Generator
| I Browse Information
3 I> Build Events
I Custom Build Step Preprocessor Definitions
b Code Analysis Defines a preprocessing symbaols for your source file,
< >

oK Cancel Apply



e Then, add the following:
_CRT_SECURE_NO_WARNINGS and ...NO_DEPRECATE

Preprocessor Definitions ? >
_CRT_SECURE_NO_WARNINGS A
‘“E;'E‘;jG Purpose: Adding
1~ v _CRT_SECURE_NO_WARNINGS and
] _CRT_SECURE_NO_DEPRECATE to
I| Evaluated value: Preprocessor Definitions
| ﬁlﬁg_;ECURE_NU_WMNlNGS A removes/supresses the precompiler
_DEBUG secure warnings that come up when you

build the project.

Inherited values;

1| _UNICODE
3| UMICODE

[] Inherit from parent or project defaults Macros> =

QK Cancel




6.5 Command Arguments

* Project Properties > Configuration Properties > Debugging >Command Arguments
e Add one of the following argument to your project:

i) camera: is for real-time tracking using the webcam.

ii) frames: apply Optical flow between two frames.

Optical_Flow Property Pages ? X
Configuration: | Active(Debug) ~ | Platform: | Active(Win32) ~ Configuration Manager...
4 Configuration Properties Debugger to launch:
Geneial Local Windows Debugger ~
Debugging
EC(;” Disciopes Comman d S(TargetPath)
b .! o Command Arguments frames w
b Linker Working Direct ${ProjectDi
b Manifest Tool orking Directery (ProjectDir)
I XML Document Generator| Attach Mo
Debugger Type Auto

I> Browse Information

I Build Events Environment

I Customn Build Step Merge Environment Yes
I Code Analysis 50L Debugging Mo
Amp Default Accelerator WARP software accelerator

Command Arguments
The command line arguments to pass to the application.

Cancel Apply




Do the following for each .cpp file:

Select the file in the solution explorer. Click on properties. Select the C++ options. Choose precompiled
Headers. Select none.

NOTE: For VS2015 and older, you don’t need to do this step.

Solution Explorer AR stdafx.cpp targetver.h stdafich between.cpp & X
GE- -5 Fm| o "'E %] Optical_Flow -1 (Global Scope) -
- § A - 1 =i#include “stdafx.h" )
Search Solution Explorer (Ctri+ P - #include "between.h" .
151 Soluticn 'Optical_Flow' (1 project) 3 i
4 [%] Optical Flow 4 void load (Imag char**);
b e References ] void get_corne I .
b ¥3 Extemal Dependencies 2 sl i:fa_si‘fanadg {
b HeaderFiles void disp
3 Resource Files
4 sl SourceFiles L Jint betwe Configuration: | Active(Debug) v | Platform: | Active(Win32) w | Configuration Manager...
b ++ between.cpp 11 {
b [ between.h pis = /7 Youl | 4 Configuration Properties Precompiled Header Not Using Precompiled Headers «|
P [ commonh = . aj: General Precompiled Header File Create (/Y¥c)
14 W
b ey pyrkcop - 4 C/Ces Precompiled Header Output File | Use (/Yu)
P+ Optical_Flow.cpp 16 General Not Using Precompiled Headers
++ stdafu.cpp Optimization
[ stdafch f Preprocessor
[ targetver.h n Code Generation
b *++ Tracker.cpp t2 Language
b [ Trackerh Precompiled Headers
; Output Files
s Browse Information
i, rowse Informatios
I corne Advanced
26 All Options
2 Coemmand Line
/1)
load(|
100% -
oupu I ¥
Show output from:  Build
s Precompiled Header : S
;slun\suur(e\repos\np Create/Use Precompiled Header : Enables creation or use of a precompiled header during the build.  (/Y¢, /Yu) | St VoL durE e aiad il s
tsion\source\reposiod | | der. Did you forget to add '#inc
Code. ..
ing project "Optical] OK Cancel Apply
4ild: @ succeeded, 2,
SRS W Class View  Property Man...  Team Explorer B 3

Repeat the above step for all .cpp files.



6.6 Run The Project/Solution

e Save the project. F
e Start debugging (F5).

- -] E I i ] = [o] x [(mireme) P

| i 5




7. Code Analysis

Load Image 1

Interest Points

KLT Tracker using
2 images




7.1 KLT Tracker

e Detect Harris corners in the first frame

™

N

“flat” region: “edge”: “corner”:
Nno change in no change significant
all directions along the edge change in all

direction directions

P—



Lowest resolution level

7.1 KLT Tracker
e Build the Optical Flow Pyramid

Original resolution level /ASESEEE

Pyramid Levels

Distancein pixels
the object moved
between frames

Filtering
applied on all
resized images

Initial
filtering

Gaussian pyramid of image H Gaussian pyramid of image |

(a) (b)



e For each Harris corner compute motion between
consecutive frames

e Link motion vectors in successive frames to get a
track for each Harris point




Thank You
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